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Preface

Welcome to TerraAmazon

TerraAmazon is a GIS tool designed to be a multi-user editor of geographic vectorial data stored in a
TerraLib model database. It engages land use and land cover classification tools as well as spatial
operations between vector data, allowing transitions analysis among other applications. TerraAmazon
keeps work time records for project control. It´s functionalities are extensible through plugins, such
as the already existing TerraImage (PDI) and TerraPrint (plotting).

TerraAmazon was first developed by INPE and FUNCATE in early 2005. It was initially applied to
SISPRODES project and quickly conquered space in other projects, such as DETER and DETEX,
among others,  due to  its  multi-user  characteristic.  Until  late  2009,  TerraAmazon was  used  only
within FUNCATE, being widely applied to many of its projects. With the creation of CRA, INPE´s
Amazon  Regional  Center,  located  in  Belém,  TerraAmazon  reached  international  space,  having
regular trainings being held in CRA´s facilities for both national and international specialists.

Nowadays, TerraAmazon is constantly being updated and having tools and system enhancements,
pursuing national and international approval.

TerraAmazon is part of Brazil´s attempt to become an international reference on forest monitoring
programmes.

TerraAmazon is free and open source provided under GPL license as published by Free Software
Foundation at www.gnu.org.

TerraAmazon is available for download at www.terraamazon.org.
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Involved Institutions

The following institutions are involved in TerraAmazon´s development process. 

INPE, Brazil´s  National Institute  for  Space  Research,  founded in 1961.  It  is  engaged on many
research  fronts  in  various  areas  of  space  science  and  their  applications.  INPE is  involved  with
TerraAmazon in the political sphere and settling agreements between countries and institutions. 

www.inpe.br

INPE Amazon (CRA, Amazon Regional Center) is an INPE unit settled in Belém, State of Para, and
east  of  the  Brazilian  Amazon.  Founded  in  2007  to  support  researches  and  fieldwork  in  the
Amazonian  region,  this  unit  became fully operational  in  2009 and since  2010 implemented  the
International Course on Tropical Forests Monitoring. This capacity building activity is based on the
knowledge  of  the  TerraAmazon  System,  for  which  documentation  and  training  tutorials  were
developed enabling  participants  from Latin  America,  Africa  and Asia  countries  to  monitor  their
forests, as Brazil has been doing for more than 20 years. 

www.inpe.br/cra

FUNCATE,  Foundation for Space Science,  Technology and Applications,  is  a non-profit  private
organization founded in 1982. It is engaged on national projects involving land use and land cover
classification, estimating GHG emissions due to land use as well as many others. It has technical
agreements  with  Brazilian  research  partners,  such as  INPE,  CTA (Aerospatial  Technical  Center,
Brazilian Air  Force)  and others.  FUNCATE is involved with TerraAmazon by programming the
software, developing and enhancing tools, testing, writing user´s guides such as this one, developing
and maintaining the website as well as other related activities.

 www.funcate.org.br
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TerraAmazon Documentation

TerraAmazon has the following documentation available for download at www.terraamazon.org:

User´s Guide Administrator: defines the administrator roles and presents the use of each interface
related to administration procedures.

User´s Guide Operator: defines the operator roles and presents each procedure for working on multi-
user environment and the use of each vectorial edition tools.

Edition Plugin User´s Guide: presents each procedure for image edition.

Digital Image Processing (DIP) Plugin User´s Guide:  presents each procedure to process digital
image.

Digital  Terrain  Model  (DTM) Plugin User´s  Guide:   presents  each procedure  to  model  digitally
terrain surfaces.

iii
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1 Introduction to TerraAmazon

WHAT IS TERRAAMAZON             1

PRESENTING THE MAIN INTERFACE            3

What is TerraAmazon

TerraAmazon is a GIS tool designed to be a multi-user editor of geographic vectorial data.

It was developed to improve the corporate production of geographic data in order to provide an
accurate  measurement  of  deforestation,  forest  degradation,  land  use  and land  cover  change  and
similar applications.

In TerraAmazon, several users can work simultaneously in the same data following a methodology
fixed by Administrator Users. This reduces the time of project execution and ensures that the final
data is entirely produced under the same methodology.

The spatial operations between vector data allow transitions analysis among other applications.

The system has a built-in structure to allow experienced users to audit the data produced. It also
provides reports so Project Managers can follow and analyze the evolution of the work.

The data is stored in a TerraLib model database (www.terralib.org) and is worked within a client-
server environment.

Database

A TerraAmazon database encloses the whole set of data, either raster or vector data.

Layer

Vector or raster data. Every vector or raster data stored in the database is presented to the user as a
layer in the Layers Tree (see the main interface on page 3).

Vector data can have three types of representation: polygons, lines or points. 

Layers are visible to all users.

Theme

1
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A theme is a structure that defines which data from one particular layer will be visualized and how
will it be displayed on the screen. Themes are user-related, that is, if a user creates a certain theme,
he will be the only one able to see it, change it or remove it.

No user can see other user´s themes, not even having administrator privileges.

View

A view is a structure that defines the data that will be visualized and manipulated simultaneously.
That is, if the user needs to visualize a satellite image and a vectorial data at the same time, both
these data must be added to the same view. Views are user-related, that is, if a user creates a certain
view, he will be the only one able to see it, change it or remove it.

No user can see other user´s views, not even having administrator privileges.

2



Chapter 1

Presenting the Main Interface

The following figure presents the main interface. It has three main areas:

• Database & Layers Tree

• Views & Themes Tree

• Drawing Area.

In the Database & Layers Tree, the icon  identifies the currently connected Database, while the
icon  identifies the layers. This tree is shown the same way for every user since it contains every
single layer in the database.

In the Views & Themes Tree, the icon  identifies the views, while the icon  identifies the themes.
This tree is different for each user since both views and themes are user custom.

The drawing area displays the data from the selected themes in the current view.

The  other  items  in  the  interface  are  shown  only  in  specific  conditions.  The  Drawing  and
Classification Tools, as well as the  Current Layer in Edition, only show when the user opens the
edition mode. The  Navigation Tools are shown all the time. The number of the connection Port is
shown only when informed by the user at the moment of the database connection.

3
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2 Accessing the Database

CONNECTING TO A DATABASE            6

CHANGING PASSWORD            7

Procedures to perform the connection with an already existing database, previously configured by an
Administrator User.

Operator Users cannot create new databases. Contact an Administrator user if needed.
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Connecting to a Database

To connect to an existing database, that is, to start a working session in TerraAmazon, click on the
icon  or go to the menu FILE\ OPEN DATABASE.

The Connect operation must be selected.

Contact an Administrator User to inform the options to be chosen or typed on the fields  Database
Type, Host and Port.

Type your user name and password. For your first connection, an Administrator User must create
both user name and password for you. Once you connect, it is advised to change your password and
keep it safe (refer to Changing Password, on page 7)

Next, click on the Select Database button and choose the database you need to connect.

The option Load Views On Demand determines if the contents of the views owned by the user will be
loaded at the time of connection:

• If selected, then only the list of views on the Views Tree will be loaded and the connection will
be faster. In this case, the user must click on each desired view in order for its themes to be
loaded and enabled for visualization and work.

• If  unselected,  every  theme  from  every  view  owned  by  the  user  will  be  loaded  during
connection. This will increase time demanded for the connection if the user has many views
and each one  having many themes.  It  is  advised  to  check this  box when working on the
corporate environment.

6



Chapter 2

Changing Password

Operator users may change their own password at any time by going to the menu FILE\ CHANGE
PASSWORD after connecting to the database.

Inform the old password and type the new password on their  respective fields.  Repeat  the new
password on the field Repeat.

Click on the Save button to apply the password change.

If the user has forgotten his password, contact an Administrator User to have a new password set up.

7



3 Digital Image Processing - DIP Plugin

IMAGE PROCESSING          15

FUNCTIONS          69

PALETTE          87

SYNTHETIC APERTURE RADAR (SAR)          96

RASTER REMAP        101
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Introduction to Image Processing

Image processing is computer based image handling, and process input and output will be images.
The process input is an image and the output is a classification or description of it. The computer
chart area involves the image generation based on its descriptions.

The  objective  to  use  digital  image  processing  is  to  improve  visual  aspect  of  certain  structure
appearance to the human analyst and provide other subsidies to its interpretation including product
generation that can be submitted to later processing

DIP techniques besides allow analyze a scene in many electromagnetic regions of the spectrum, also
make possible to integrate many data types and registered accordingly.

DIP happens in three different independent steps: preprocessing,  improvement and classification.
Preprocessing  refers  to  the  initial  processing  of  raw  data  to  radiometric  calibration  of  image,
geometrical distortion corrections and noise removal. More common improvement techniques in PID
are  contrast  improvement,  filtering,  arithmetic  operations,  IHS transform and main  components.
Classification techniques can be divided in supervised classification (per pixel) and non-supervised
classification (per region).

Note:  user  can  choose  not  to  use  classification  algorithms  once  he  can  opt  to  use  direct
interpretation on improved image.

DIP techniques are performed always with gray levels assigned to pixels in an image. Depending on
involved technique user will work with only one image (band or layer) or with several images, the
most known is the multi spectrum technique handling several images of the same scene in different
electromagnetic spectrum.

10
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Starting DIP plugin

To start editing images click on the DIP plugin icon  in TerraAmazon main menu. DIP window
opens.

See description of DIP Plugin menu icons in chapter 5, Tools)

11
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Display Handling

The display tool allows adding and organizing new displays on the drawing area in order to view
them simultaneously. 

Click on the display icon and select the proper tool.

Background Color: this tool changes the color of  the background.

Add Display: this tool adds a new drawing area. Once you clicked in this option a new window opens
and user can select the theme and draw it.

Tile Displays:  this organizes displays on visualization area so they are visible and aligned, tiling two
or more images.

Cascade Displays: this tool organizes images on the visualization area cascading them.

Display tools: this tool activate or deactivates the display toolbar.

12
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Link Display: this tool links two displays and action executed in one display is repeated in the other.
Click on the  Link button and  click on the  OK button. Move to visualization area and operation
executed in one will be repeated in the other.

Box: this tool allows a definition of box size using the mouse and drag it over the image showing  the
equivalent image of the other. Click on Box button and choose the number of each display involved
in the operation. Click on the OK button.

Overlay: this tool overlays data of two different displays. Click on the Overlay button and choose
the number of each display involved in the operation. Click on the OK button. Adjust on the slide
button to overlay one display on  another.

13
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Flick: this tool shows alternately the data of two different displays. Click on Flick button, choose the
number of each display involved in the operation. Click on the  OK button.  It can be set to flick
manually and changing image by clicking on the lower Flick button or automatically and user sets
the flicking speed on the slide button beside this option.

14
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Image Processing

Improving Image Contrast

The contrast operation is used to enhance the visual quality of the image represented by a raster file.
The available methods in TerraAmazon are:

Negative:  The contrasted image will  be created by using linear inverse mapping, i.e.,  the
function applies the algorithm and dark areas (low values of gray level) become clear (high
values of gray level)

Equalizer Using this method, the histogram of the image will be equalized automatically.

Linear: The user defines a new minimum and maximum value for the pixels in the image.
The algorithm then applies a linear function over the pixels using those 2 values.

Log: The contrasted image will be created by using a log function.

Square: The contrasted image will be created by using a square function.

Square Root: The contrasted image will be created by using a square root function.

Activate and visualize the layer that need contrast improvement.

Zoom  in  the  area  of  interest.  Select  IMAGE  PROCESSING  →  IMAGE  PROCESSING  →
CONTRAST in the main menu. Contrast window appears.

Choose one of the available mapping functions available, for instance: Linear.

15
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Select the histogram area. If you select Use ROI, click on the New ROI button and select an area

with the pointer.

By  selecting  the buttons it is possible to view histograms for RGB bands.

Left click with mouse to define the minimum value followed by right click with mouse to define the
maximum value.

Click on the icon  to see the new contrast.

If result is fine, then decide if the new contrast will be applied only to the theme keeping original
digital values of the layer.

In case the new contrast is to be a new layer click on the icon .

If result is not fine, the user can reset to original values clicking on the icon  .

16
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Registering Images

Image registration is a process of aligning two images acquired by the same/different sensors, at
different times or from different viewpoints. Many image processing applications like remote sensing
for change detection, estimation of wind speed and direction for weather forecasting, a fusion of
medical images need image registration.

To register images, we need to determine a geometric transformation that aligns images with respect
to the reference image. The most common transformations used are:

rigid (RST),

affine,

perspective.

The parameters of the geometric transformation are calculated based on a given set of tie-points. 

The tie-points can be obtained manually or automatically as follows:

Manual  method:  in  this  case  the  algorithm will  generate  the  registered  image  based  on
manually selected tie-points,

Automatic method: in this case, the tie-points are automatically generated by other algorithm
comparing the input image with another reference image. The generated tie-points are later
used by the register algorithm to generate the registered image.

Select  IMAGE PROCESSING → IMAGE PROCESSING → REGISTER in the main menu.  In
lower right corner appears register parameters split into different tabs and point control tools.

Input Tab:

Reference view: define the image that will be used as the reference.

Reference theme: define the theme that will be used as the reference.

Adjust view: define the image that will be used to adjust.

Adjust theme: define the theme that will be used to adjust.

18
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Band: define in both image the band value.

Click on the Draw button and both images will be shown.

Output Tab:

Layer name: enter the name of the resulting image.

Projection: click on this button if projection parameters need to be adjusted by the user.

Resolution: choose one of the alternatives: from reference, from adjust or used defined.

Properties Tab:

Geometric Transformation: define one of available transformation types.

Interpolation: define one of the available interpolation methods.

Register Type: define manual or automatic.

19
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Options Tab:

Load Control File: if the user wants to use a saved configuration file click on this button, browse the
path and select the file.

Save Control File: if this register configuration is to be saved for further use click on this button,
browse the path and enter the file name.

Register:  choose  which  type  will  be  used  in  the  process:  enable  pregeo,  centralize  point  when
selected or register only visible area.

Information Tab

It will be presented information related with previously selected choices. The option Error will be
shown  after  the  insertion  of  needed  points,  option  Geo  Transform  is  the  chosen  operation  in
Properties Tab, option Acquired Tie Points is the collected points so far, option Necessary Tie Points
shows the quantity of needed points related with the Geo Transform chosen.

Select the reference window.

Click on the zoom area icon and define an area to collect points.

Select the adjust window.

Click on the zoom area icon and define the same area of the reference area to collect points.

Click on the reference window.

Click on the icon Add Tie Point  in the tool bar. 

Select one point in the reference window. 

Note: at this moment, the point is not yet created in the list, so the user can click in other positions
in the reference image to improve the positioning.

Click on the Adjust window.

Click on the icon Add Tie Point in the tools bar. 

Define the same point in the adjust window. 

20
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Note: at this moment, the control point list is updated.

Repeat the process until there is enough control points added. 

Note: Remember to select control points spread all over the image.

 Other possible ways to select points are:

Add tie point by click  : it is needed for user intervention to collect a point in reference and adjust
windows by mouse clicking.

Add  Tie  Point  by  Keyboard  :  used  to  reference  points  via  keyboard  entering  geographical
coordinates of control points.

Move Tie Point  : If a tie point is inserted in a wrong place, the user can move it to a correct
position. 

Delete Tie Point  : User can select one point in point list and delete it. 

Guess the Point  : After a control point selection in the list, it is highlighted in reference and adjust
windows. 

Acquire Points  : this tool must be executed when the register type is in automatic mode.

After all control points have been collected, the user should click in icon Execute Register . 

Click on the button Yes to end the register.

The new layer will be presented under the database/layer tree and in views/themes tree.

21
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Segmentation of an Image

Image  segmentation covers techniques for splitting one image into several homogeneous regions.
The  Segmenter  interface  implements  methods  to  segment  a  raster.  The  available  methods  in
TerraAmazon are:

Region  Growing: Creates  regions  by  merging  similar  neighboring  pixels.  To  reduce
processing time, the raster is divided into pieces, and such pieces are segmented individually.

Based  on Baatz  and Shape: Creates  regions  by merging  similar  neighboring  pixels.  The
resultant regions must fit a predefined scale and compactness, provided by the user.

Input:

One Raster,

A vector of band indexes used to perform segmentation.

Output:

One Raster with a single band, where the pixel value stands for the index of the region to
which it belongs

Select IMAGE PROCESSING → IMAGE PROCESSING → SEGMENTATION in the main menu.

Select the image to be segmented in Raster Image and enter parameters accordingly.

Raster Mask: select on the list the appropriate mask.

Type: choose between the region growing or Baatz method.

Configuration Parameters:

Euclidian Distance Threshold: insert value to be used as similarity threshold. (It must be integer and
greater than zero, e.g. 16).

Minimum Area: this value will be used as minimum area size, in pixels, representing the segmented
region. (It must be integer and greater than zero, e.g. 8).

Scale: enter the scale value. (Baatz)

Compactness: enter the compacteness value. (Baatz)

Color: define the color value. (Baatz)
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Workspace: 

Use Region of Interest: if the user wants to select a part of the image manually, select this box and
click on the New ROI button.

Output Parameters:

Layer name: enter the name of the resulting image generated.

Projection: click on the button to open the projection window and adjust parameters if necessary.

Optimized Processing: if this box is selected the processing is executed in parallel mode, the system
cuts data arbitrarily and utilizes the available processors. As a process that may take a long time
depending on image size and the region quantity that may be generated, it is strongly recommended
using this optimization to make processing faster.

Click in the OK button.

23
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Classifying Images

The classifier  implements methods to detect patterns in image regions.  Commonly,  classification
algorithms are divided by the level of classification (pixel or region), and by the interaction of the
user  (supervised  or  unsupervised).  Pixel-based algorithms classify individual  pixels  according to
their resemblance to a specific pattern. Region based algorithms use regions from segmented images
and classify each region to a specific pattern. The supervised method uses a predefined typology,
given by the user, who supplies samples of each pattern. Unsupervised methods detect an unknown
number of patterns, according to their own method. 

The available methods are: 

ISOSeg

This is an unsupervised and region-based classification algorithm to classify regions in a segmented
image  applied  on  a  region  set  that  will  be  characterized  by  its  statistical  attributes  of  media,
covariance matrix and area. 

Input:

Raster

Vector of polygons

Acceptance threshold

K-Means

This is an unsupervised and pixel-based classification algorithm.

Input:

Raster

The value of “K”, which stands for the number of patterns to find in the image.

A convergence threshold.  When the  clusters  move less  than  this  threshold,  the algorithm
stops.

Maximum number of iterations.

Select IMAGE PROCESSING → IMAGE PROCESSING → CLASSIFICATION in the main menu
and adjust the parameters.
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Input Parameters:

Classification Method: Select between K-means or Isoseg method.

Layer Name: Select the layer to be classified.

All Band: select this button to use all bands, otherwise click on Select Bands and enter bands to be
classified.

Method Parameters:

Number of classes: insert the number of distinctly identified areas.

Interactions: insert the number of times this process will be repeated.

Polygons Layer: If Isoseg method is chosen the user must indicate which layer contains the resulting
polygons of the segmentation.

Acceptance Threshold : enter the percentage of  pixels probability distribution of a class that will be
classified as belonging to this class.  A threshold of 99 means that 99% of pixels will be considered
while 1% will be ignored (those with lower probability). It defines the Mahalanobis distance, so all
regions belonging to a certain class are distant of a class by a distance lower than this one. Higher the
threshold, higher the distance and consequently bigger will be the number of detected classes by the
algorithm. 

Output Parameters:

Generate Layer: if the result is to be saved in the database click on the box and enter the name of
generated layer (the image will be presented in view tree).

Generate Tiff: if the result is to be saved in a file click on the box and on the button File to browse
and enter the file name (the image will be saved in a .tiff file).

Click in the OK button.

25
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Supervised Classification of Images

Supervised classification is used when there are image regions where the user has information that
allow interest class identification.

The user must identify in the image a representative area of each class. It is important that supervised
area is a homogeneous sample of respective class but at  the same time must include all gray level
variation of the theme.

It is recommended user acquire more than one supervised area using the biggest number of available
information such as field work, maps, etc.

To obtain reliable statistical classes, it is necessary from 10 to 100 pixels of samples per class. The
number of pixels to an acceptable accuracy of a class increases with the variation increase among
classes.

Select IMAGE PROCESSING → IMAGE PROCESSING → SUPERVISED CLASSIFICATION in
the main menu. 

In opened window select bands 1 and 3 and click on the right arrow button.

Click on the button Sample Acquisition.

Region of Interest window opens.

26
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Options:

Click on Create New Samples By and choose one of the 3 options: ROI, Points Theme or Polygons
Theme.

If previously saved samples will be used instead of create a new one click on  Load Samples and
click on the File button to browse and find the file.

Select the option Region of Interest.

Click on the Next button.

27
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Name: enter the name of the first class, e.g. water.

Click on the Color button to define the class color, e.g. blue.

Click on the Create button.

Enter another name to create one more class.

Click on the Color button to define color of the second class, e.g. red.

Click on the Create button.

Create and attribute a color to all selected bands repeating the same procedure. When finished click
on the Next button.
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Class: select one class created in previous window to insert the samples.

Click  on  the  icon   or   to  draw polygons  or  rectangles  in  visualization  area  and do sample
collection, to close the polygon click with mouse right button. Acquire as many as samples needed.

An alternative to sample pixels is the magic wand. Click on icon  and then use the mouse to select
correspondent pixel to the class.  Besides the pixel selection button there is a slide button to adjust
the threshold.

Transparence: changes the visualness percentage of the generated polygon.

Select the second class and repeat same procedure until finish all available classes.

Click on the OK button.
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To save created samples click on the icon  and define a path and file name.

Click in OK button.

Click on the Classification button. 

Enter the name of the classified image in Output Image Name field.

Select the classifier.

To verify created samples, click on the Samples Analysis button.
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Click on the Export button if the result is to be saved in a text file.

If not, click on the Close button and return to the previous window.

Click on the OK button to execute classification process.

Click on the Post Classification button.

In Weight and Threshold slide buttons define and input values.

Enter the name of the resulting image that will be generated in  Image Name field and it will be
displayed in the view/theme tree.
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Supervised Classification using a Point Table

Select IMAGE PROCESSING → IMAGE PROCESSING → SUPERVISED CLASSIFICATION in
the main menu. 

In opened window select bands 1 and 3 and click on the right arrow button.

Click on the button Sample Acquisition.

Region of Interest window opens.

Click on the box Points Theme and choose the point view.

Click on the Next button.
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Attribute: select the attribute that will be used to create classes.

Colors: choose the colors scheme to be used in the classification.

Click on the Apply button and classes will be automatically created.

Click on Next button.

Choose a tolerance and click on the icon  to automatically create samples.

34



Chapter 3

Note: The difference between this tool and the magic wand tool is that it uses the coordinates of
points as the basis for polygons creation, not the coordinate of the mouse click. This tool only use
the points that intersects with the visible area.
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Click on the OK button.

Click on the Classification button.

Output Image Name: enter the name of the classified image.

Classifier: select the classification method.

Click on the OK button.
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After  the  image  classification,  the  user  can  be  used  to  validate  the  classification  to
determine  the  reliability of  the  result.  This  tool  is  located  on  menu IMAGE PROCESSING →
PALLETE.

Classified Image:

Layer Name: select the layer from classification result.

Sample Layer:

Layer Name: select the point layer in sample acquisition.

Class Column: select the attribute that indicates the classes.
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Select the layer from classification result, the layer of points used in samples acquisition and the
attribute that indicates the classes and make the association of classes.

Click on the OK button.

A report showing the number of computed samples, sampling factor, error rate and kappa index is
generated.
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Color Transformation

The color transform operation is used to change the color system of an image. The available methods
in TerraAmazon are:

RGB to IHS: Converts the system color of the image from RGB to IHS.

IHS to RGB: Converts the system color of the image from IHS to RGB.

RBG to HLS: Converts the system color of the image from RGB to HLS.

HLS to RGB: Converts the system color of the image from RGB to RGB.

Select IMAGE PROCESSING → IMAGE PROCESSING → COLOR TRANSFORM in the main
menu.

Transform: select the type of transformation to be executed in the image.

Input Parameters:

Click in each channel (R, G or B) and select image to be transformed. If the image will be the same
for all, when selecting R all remaining channel will use the same image.

Output Parameters:

Generate Layer: Click on this box to save generated image to the database. Insert the name in Layer
Name field.

Generate TIFF: Click on this box to save generated image in a file. Click on the File button, browse
the path and enter the file name.

Bits per Pixel (bpp): select the number of bits per pixel

Dummy: enter the pixel number to be used as dummy
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Click on the OK button. Information window opens.

Confirm with Yes if you want an instantaneous display.
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Image Fusion

The  fusion operation allows combination of images with different spectral  and spatial  resolution
keeping the radiometric information. A huge effort has been put in developing fusion methods that
preserve the spectral information and increase detail information in the hybrid product produced by
the fusion process. The available methods in TerraAmazon are:

IHS: Fusion of a low-resolution multi-band image with a high-resolution image using the IHS
method. The IHS method consists on transforming the R,G and B bands of the multispectral
image into IHS components, replacing the intensity component by the panchromatic image,
and performing the inverse transformation to obtain a high spatial resolution multispectral
image.

Principal  Components Fusion: Fusion of a low-resolution multi-band image with a  high-
resolution image using the PCA (Principal components analysis) method. The PCA performs
image fusion where the first principal component of the multi-spectral image is replaced by
the histogram matched panchromatic imagery.

Select IMAGE PROCESSING → IMAGE PROCESSING → FUSION in the main menu.

Input Parameters: 

Fusion type: select from the list the fusion type.

Resampling Type: select from the list the resampling type.

Reference Raster: click on the Layer button and choose the layer used as the reference.

Lower Resolution Raster: click on the Layer button and choose the second layer.

RGB Bands: select the fusion bands.
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Output parameters:

Use Only Visible Area: click on this box to fuse visible area.

Generate Layer: click on this box to save the resulting image in the database entering the name in
Layer Name field.

Generate TIFF: click on this box to save resulting image in a file. Click on the File button to browse
and enter the file name.

Click in the OK button.
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Arithmetic Operations

The arithmetic operations allows the user to perform operations on one or more images of the same
geographical area. In addition to the operations that can be made between the bands of the images, it
is also possible to apply gain and offset to the images. 

The operation is pixel-based using the defined mathematical rule (sum, subtraction, division and
multiplication for a constant (linear enhancement), resulting in a band representing a combination of
original bands.

These operations allow data compression reducing the number of bands but in other hand there is
original information loss. The operation results can be over range 0-255 and those results will be
automatically  normalized  thus  saturating  values  below  0  and  over  255  retrospectively,  causing
spectral information loss.

These operations may require a gain (multiply) or offset to improve image contrast quality. The value
definition depends on user skills, in operation definition among bands and spectral characteristics of
used bands.

In general, sum operation is used to improve similarities between bands or different images while
subtraction, multiplication and division is used to improve spectral differences.

Some standard operations are defined in the interface:

•Gain * R0 + Offset

•Gain * (R0 +R1) + Offset

•Gain * (R0 - R1) + Offset

•Gain * (R0 / R1) + Offset

•(Gain * (R0 - R1) / (R0 + R1)) + Offset

•(Gain * (((R0²) + (R1²))0.5)) + Offset

Select IMAGE PROCESSING → IMAGE PROCESSING → ARITHMETIC OPERATION in the
main menu.
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Input Rasters:

Layers: select the previously imported layer in the database and click on the Add button. Layers are
presented in the list below. Select their correspondent bands.

Operation Parameters:

Operation: select one of the available arithmetic operations.

Params: enter the gain value and offset value

Normalize Output Raster: click on this box if the result is to be normalized.
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Output parameters:

Generate Layer: click on this box if the resulting operation is to be saved in the database. Enter the
name in Layer Name field.

Generate TIFF: click on this box if the resulting operation is to be saved in a file. Click on the File
button and browse the path and enter a file name.

Click on the OK button.

Click on the Yes button and the image will be showed in the visualization area. It is also showed in
Views/Themes tree.
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Filtering Images

The concept of filtering involves neighborhood operations work with the image pixel values in the
neighborhood and the corresponding values of a sub-image that has the same dimensions as the
neighborhood. The filter operation can be classified as:

Linear:

It can be executed in the spatial domain through convolution operation and in the frequency domain
by  product  operation.  It  smooths  and  highlights  image  details  and  reduces  noise  effects  not
changing the image average. 

Low-pass: this filter would pass low frequencies and block (filter out) high frequencies. In
practice, this is easily achieved in the spatial domain by the M = N = 3 kernel. Examples are
mean filters 3x3, 5x5, and 7x7.  The image can be smoothed (blurred) using this filter.

High pass: this filter attenuates the low-frequency components and image can be sharpened
and edge-enhanced.

Non-directional: this filter can enhance edges regardless of direction. The three masks differs
in the intensity of high values of gray level in the resulting image. The high mask filters the
low levels of gray and image becomes clearer. The low mask produces a darker image. The
median mask produces intermediate results. 

Directional:  enhance  edges  according  to  the  preferred  interest  directions  defined  by  the
masks. The mask names indicate the preferred orthogonal direction in which borders will be
enhanced. Thus the North mask enhances horizontal edges.

TM enhancement: Utilizes proper masks to enhance image characteristics obtained by specific
sensors. To TM/Landsat images, the enhancement compensates radiometric distortions of the
sensor. The pixel will have its gray level value replaced by the applied mask corresponding to
the shadowed position. 

Edge Detection

Local  discontinuities in image luminance from one level to another are called luminance edges,
limited to image amplitude discontinuities between reasonably smooth regions. There are two major
classes of differential  edge detection: first- and second-order derivative. For the first-order class,
some  form of  spatial  first-order  differentiation  is  performed,  and  the  resulting  edge  gradient  is
compared to a threshold value. An edge is judged present if the gradient exceeds the threshold. For
the second-order derivative class of differential edge detection, an edge is judged present if there is a
significant spatial change in the polarity of the second derivative.

Sobel: The Sobel operator edge detector where the mask values of the north, south, east, and
west pixels are doubled. The motivation for this weighting is to give equal importance to each
pixel in terms of its contribution to the spatial gradient.

Roberts: Diagonal edge gradients can be obtained by forming running differences of diagonal
pairs of pixels. This is the basis of the Roberts cross-difference operator:

Morphological Filters

Morphological image processing is a type of processing in which the spatial form or structure of
objects within an image are modified.  Dilation and erosion are three fundamental morphological
operations.
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Dilation: With dilation, an object grows uniformly in spatial extent, whereas with erosion an
object shrinks uniformly.

Erosion: With erosion, an object shrinks uniformly.

Mode: The Mode filter is used to remove noise from an image by replacing pixels with the
most frequently occurring pixel value selected from a certain window size.

Median:  A median filter, which, as its name implies, replaces the value of a pixel by the
median of the gray levels in the neighborhood of that pixel (the original value of the pixel is
included in the computation of the median). Median filters are quite popular because, certain
types of random noise, they provide excellent noise-reduction capabilities, with considerably
less blurring than linear smoothing filters of similar size.

Opening: it is obtained by chaining of erosion filter, followed by dilation filter.

Closing: it is obtained by chaining of dilation filter, followed by opening filter.

Radar

The radiometric quality of SAR data is affected by inherent factors of the instrument and light
geometry.  The  two  main  causes  fo  radiometric  distortions  that  affect  image  interpretation  are
speckle noise and antenna pattern.

Frost: it is a linear convolution filter and adaptative that preserves the edge structure.

Lee: adopts a multiplicative model to the noise and uses the criterion of local linear minimum
mean square error. It is an adaptive and general filter.

Select IMAGE PROCESSING → IMAGE PROCESSING → FILTERS in the main menu.

Input Layer: Click on the Search button and select the layer to be filtered. 
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Parameters:

Filter Type: select the filter type to be applied on the image. Depending on the selected type different
and additional parameters field will appear below, e.g., if a morphological filter is selected another
parameter (Morph Type) appears and proper value should be setup.

Options:

Filter Mask: Select mask to be used in filtering operation. Depending on the filter type, there will be
different masks to be selected. The mask will be applied in the center position (i,j) where i is the
number of rows and j is the number of columns on the image. It replaces the pixel value in position
(i,j) by a new value that depends on the neighbor pixels and the mask weighs, generating a new
image with removal of initial and final rows and columns.

Interactions: enter the numeric of interactions.

Output Parameters:

Generate Layer: click on the box to save the resulting image in the database entering the name in
Layer Name field.

Generate TIFF: click on the box to save resulting image in a file. Click on the File button to browse
the path and enter the file name.

Click on the OK button.

To see the produced image in visualization window click on the Yes button. 
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Applying Texture Filter

Many images have regions characterized by brightness variations. The texture filter refers to spatial
variations in image tones as a scale function. Specially to aerial photos, applying texture filter is
recommended.

To the analyst is easy to recognize the texture differences in an image. The quantification through
digital processing is more complex because there is not a general definition of texture. Different from
spectral characteristic describing the object tone variations. In addition, theses tone variations can be
considered as a scale function in which the object is observed.

Select IMAGE PROCESSING → IMAGE PROCESSING → TEXTURE FILTER in the main menu.

Texture Filters: click on the box to choose the filter to be applied on the image. 

Use co-occurrence measures filter to apply automatically 8 different texture filter types based on co-
occurrence matrix. 

The occurrence filter uses gray tones in function of texture value calculation matrix. This matrix is
the frequency matrix relative to which the pixel values occur in two neighborhood of the processing
window separated by a specific distance and direction. Then it is showed a number of occurrences
between a pixel and its specified neighbor. 

Texture to Compute: Select needed texture type.

Processing Window: select the option of rows x columns correspondent to considered area (pixels)
for texture evaluation. 

Bands: click on the box to select to apply to all band or to select one band.

Output Parameters:

Layer Name: enter the name of resulting image.

Click on the OK button.
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It will be created a layer to each selected texture filter.

Note: Depending on the filter, there will be different filter types. 
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Mosaic

The mosaic operation is used to create a mosaic from a set of rasters. Image mosaic refers to those
multi  images,  which  are  shot  in  the  same or  different  shooting  condition  and  have  overlapped
regions, are stitched and combined to an image to enlarge the field of vision that an image can cover.
The available  method in  TerraAmazon is  Geo Mosaic  that  creates  a  mosaic  from a  set  of  ego-
referenced rasters.

Select IMAGE PROCESSING → IMAGE PROCESSING → MOSAIC in the main menu.

Input Rasters:

Layer tab: select the layer from the database. 

or 

File tab: Click on the File button to browse path and select image file.

or 

Theme tab: Click on Search button and select the theme.

Note: When importing an image to the database, remember to setup dummy value to zero, to avoid
border to be showed in the image.

Selected images are displayed in Select Raster list below.

Global Parameters:

Mosaic Type: select from the list the proper type.

Select the best process to unite the image by clicking on the correspondent box.

Output Parameters:

Projection: click on this button to adjust the projection parameters to the new image
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Layer Name: enter the name for the generated image.

Click on the OK button.

To see generated image in visualization window click on the Yes button.
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Applying Mixture Model

The mixture model is a component that implements a raster decomposition using the mixture model
strategy. The spatial resolution of remote sensing satellites, in general,  allows that a single pixel
contains more than a target (for example vegetation + shadow + soil). The mixture model algorithms
allow decomposing the raster into fraction images, where the value of the resultant pixels indicates
the fraction of each target inside the pixel.

The main information needed to execute a mixture model are:

One Raster file.

A map  of  pure  endmembers,  which  are  pixel  values  where  the  user  knows  the  exact
proportion of a component.

Sensor information for each band, if available

Select  IMAGE PROCESSING → IMAGE PROCESSING → MIXTURE MODEL in  the  main
menu.

Input Layer: select the layer to apply the mixture.

RGB Information: choose the image bands with the satellite sensors.

Customize Sensor Info: when selecting this box the user can provide the spectral range of sensor not
defined in the application. 
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Click on the Create button to access components creation window for mixture model.

Sample Acquirement:

Component Name: enter the first component to be created.

Spectral Signature: select mode for pixel selection.

If  From Image is selected click on the icon  to select a specific point in the image or icon  to
select a polygon in the image.

If Manual is selected, change the values manually.

Note: For point selection zoom in visualization area over the region to improve the pixel collection.
After pixel selection, values per band will be showed to check.

Click on the Save Component button to save the sample or click on Discard Component button to
clean the selection.

Click on the Create button and repeat the procedure to save samples per component.
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Click on the Next button.

Output Parameters:

Layer Name: enter the name of the resulting image.

Note: It will be generated an image per created component.

Estimator: select the only one available Princo.

Options:

Select one of the three options:

Rescale: system rescales pixel values of output image, initially from 0 to 1, to new values from 0 to
255.
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Raster  Composition: generates  a  unique  file  Geo  Tiff  in  the  database  including  the  3  bands
correspondent to soil, forest and water proportions.

Generate Geo Tiff File: generates 3 Geo Tiff files in an indicated directory. Click on the File button
to browse the path and enter file name.

Workspace: click on the box to select if process is to be executed in all image or in the visible area.

Click on the OK button.

To see resulting images in visualization area click on the Yes button.
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Orthorectfication

Orthorectification is  the  process  of  removing  geometric  errors  inherent  within  photography and
imagery. The variables contributing to geometric errors include, but are not limited to camera and
sensor  orientation,  systematic  error  associated  with  the  camera  or  sensor,  topographic  relief
displacement and earth curvature.

Orthorectification is a form of rectification that corrects terrain displacement and can be used if there
is a Digital Elevation model (DEM) of the study area. It is based on collinearity equations, which can
be derived by using 3D GCPs. In relatively flat  areas,  orthorectification is not necessary,  but in
mountainous  areas  (or  on  aerial  photographs  of  buildings),  where  a  high  degree  of  accuracy is
required, orthorectification is recommended. 

Select IMAGE PROCESSING → IMAGE PROCESSING → ORTHORECTIFICATION in the main
menu.

Common Input Parameters:

DEM: Click on this button to browse and select saved file. Remember DEM file is an image with tif
extension and in gray scale.

Images: Click on this to select an image which ortho correction will be applied. 

Minimum Height: enter value in meters

Maximum Height: enter value in meters

Optional Input Parameters:

Control  Points:  click on this  button to  browse the .rcf  file containing the control  points.  It  is  a
generated by TerraAmazon containing control points in the image register tool.

Image Info: click on this button to browse the .txt file containing the image information.

RPC Model:

RPC: click on this button and select a file with the txt extension. The RPC file has several parameters
that allow the image orthorectification.
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Note: Check if MS3Ortho is installed before start this process.

Click on the OK button. 
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Arbitrary Operations

Arbitrary operations interface has tools that can be used to change some image characteristics such as
position, orientation, shape or size.

Select IMAGE PROCESSING → IMAGE PROCESSING → ARBITRARY OPERATIONS in the
main menu. 

Input Theme: select from the list the theme to apply the changes

Note:  an output image could or not keep input image cartographic projection characteristics. A
question will be issued when user clicks on the OK button to start up the process.

Operation:

Rotate: there are 3 possible rotate options: 90 degrees clockwise, 90 degrees anticlockwise and free
(user enter the angle value of rotation). Select one of them and click on the Preview button to verify
image result.

If resulting image is not satisfactory user can return to original image clicking on the  Recompose
button.

Flip: there are 2 flip operations: vertically and horizontally. It will create a mirror image inverting
image pixels in selected axis.

Transposition: produces a new image result exchanging row pixels by column pixels.
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Translation:  move the image.  It  is  possible  to  do the translation,  adding quantities,  in pixels or
meters, to X and Y plan.

Rescale: change image scale dimensions. It can be done in 3 methods: multiplying coordinate values
by a scale factor, changing row and column quantity or redefining a new resolution value (pixel size).

Output Parameters:

Generate Layer: click on this box if resulting image is to be saved in the database. Enter the name of
the new layer.

Generate TIFF: click on this box if resulting image is to be saved in a file. Click on the File button to
enter browse file path and enter a file name.
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Replacing Bad Values

In a DEM file, the heights are represented by a gray scale, i.e., by gray level associated to image
radiometric resolution. A DEM can be represented, for instance, by black in lower altitude region
going through gray levels  until  reach white,  where white  is  higher  altitude region.  To get  these
results, final DEM file, it is used mathematical interpolators and many other procedures to obtain the
result.  But even those statistical  and mathematical procedures are proved efficient,  it  is common
sometimes there are small fails in some image points, fails that can be generated, for instance, by the
used mathematical interpolator. Those failures are incorrect pixel values showed in the image. For
example, in certain region where there are most of 200 meters altitude values, and this altitude value
is represented by gray level 15, that is close to black in a color scale of 0 -255. Imagine inside this
region there is pixel value 255, that is white and nothing in common with the region, then this is the
incorrect value we should replace. Incorrect pixel values area also common in radar images.

Select IMAGE PROCESSING → IMAGE PROCESSING → REPLACE BAD VALUES in the main
menu

Input Parameters:

Select if the operation will be applied in full or simple mode.

From File Tab: click on the File button, browse path and select image file.

From Layer Tab: click on the Search button and select the layer.

Images will be listed below. To remove an image from the list select it and click on the icon . If
image information is needed select the image and click on the icon .

Bad Value: click on this box if the user wants to determine a specific incorrect pixel value.

Threshold Range: click on this box if the user wants to choose an interval of incorrect pixel values.
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Output Parameters:

Generate Layer: click on this box if resulting image is to be saved in the database. Enter the name of
the new layer.

Generate TIFF: click on this box if resulting image is to be saved in a file. Click on the File button to
browse file path and enter a file name.

Click on the OK button. 
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Tasseled Cap Transformation

The  Tasseled  Cap transformation  offers  a  way to  optimize  data  viewing  for  vegetation  studies.
Research has produced three data structure axes that define the vegetation information content:

Brightness – a weighted sum of all bands, defined in the direction of the principal variation I soil
reflectance.

Greenness  –  orthogonal  to  brightness,  a  contrast  between  the  near-infrared  and  visible  bands.
Strongly related to the amount of green vegetation in the scene.

Wetness – relates to canopy a soil moisture.

A simple calculation (linear combination) then rotates the data space to present any of these axes.

These rotations are sensor – dependent, but once defined for a particular sensor, the same rotation
works for any scene taken by that sensor. 

Select  IMAGE  PROCESSING  →  IMAGE  PROCESSING  →  TASSELED  CAP
TRANSFORMATION in the main menu.

Input Image:

Sensor: select the sensor to be used.
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From File Tab: click on the File button and browse path to select the image file.

From Layer Tab: click on the Search button and select the image.

Click on the Add Image button.

Input Parameters: lists with image bands and sensors. Select one sensor for each available band.

Use Only Visible Area: click on this box if transformations are to be applied in just part of the image.

Components: select one or more components to use and click on right arrow to complete selection.

Output Parameters:

Generate Layer: click on this box if resulting image is to be saved in the database. Enter the name of
the new layer.

Generate TIFF: click on this box if resulting image is to be saved in a file. Click on the File button,
browse file path and enter a file name.

Generate Image Composition: click on this box to generate image composition.

Generate Multi Resolution: click on this box to generate multi resolution image and enter the number
of levels.

Dummy: enter the pixel value.

Compression: select the compression type if needed.

Click on the OK button.
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Raster to Vector

The vectorization operation allows the user the conversion of a raster into vector.

This operation calculates a statistical summary from the pixel of a raster layer using a vector layer as
a reference.  The vector  layer  overlaps  the raster  layer  and for  each vector  object,  the operation
calculates a statistical summary of the pixels that intersects this object. This process is performed for
each selected band of the raster.

Select IMAGE PROCESSING → IMAGE PROCESSING → RASTER TO VECTOR in the main
menu.

Layer Name: enter the name of the desired layer.

Output Layer:

Layer Name: enter the name of resulting image.

Projection: Click on this button to open the window to configure projection parameters.

Click on the OK button.

Note: The raster must be a palette image.
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Classification by Decision Tree

Certain  biomes  have  a  very  complex  process  for  visual  interpretation  even  for  supervised
classification. Thus it is necessary to obtain spatial, spectral and texture attributes associated with the
particular  region  from  several  products,  parameters  and  the  image.  Obtained  attributes  can  be
interrelated to create decision rules and generate the map final legend to the target region.

As an input to do the classification it is necessary  the georeferenced matrix data and polygonal
vector of the same region. Below is the classification process to do classification by decision tree.

Select IMAGE PROCESSING → IMAGE PROCESSING → CLASSIFICATION BY DECISION
TREE in the main menu.

Load Tree: if a previous saved tree will be used click on thi button, browse and select the file.

New Class: Click on this button to create a new class in the tree. A class will appear in Tree Decision
list on the left and its properties on Class Properties on the right.

New Subclass: creates subclasses under the select class on the decision tree.
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Delete Class: select the wanted class and click on this button to delete it.

Class Properties:

Class Name: enter the name to the new class.

Color: Click on this button to change the default color to a new one.

Condition: clicking on this button will open the Attribute Query window. Insert the conditions to this
classification class using the proper attribute, attribute value and operators.
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Color Gradient

Select  IMAGE PROCESSING → IMAGE PROCESSING → COLOR GRADIENT in the main
menu. 

Input Parameters:

Layer Name: select the image by clicking on the Search button.

Band: choose one of the available bands.

Color bar: select the color bar type. Click on the Save button and enter a color bar name.

Output Parameters:

Theme Name: enter the name of resulting image.

Click on the OK button.
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Functions

Raster Composition

The term color composition consists of a combination of 3 satellite spectral bands to form a colorful
composition.  This combination of bands consists  of careful  selection,  observing if  this  selection
contains the spectral information really desired. It is important also highlight the need to select the
color allocation that have the better perception to the human eye, although the contained information
is always the same no matter the band combination and color allocation. 

Select  IMAGE PROCESSING → FUNCTION → RASTER COMPOSITION. Raster Composition
window opens.

From File tab: click on the File button to browse the file to be opened for composition. Selected files
will be showed in the list below.

Or 

From Layer tab: click on the Add Layer button and select the layer. Selected layer will be showed in
list the below.

Note: in the image list is possible to change band of each image.

Storage Parameters:

Layer Name: Enter the name of layer to be created in the database

Compression: Select the compression method to be used or not.

Dummy: insert the pixel value for the dummy.

Generate Multi Resolution: Select this option to create more than one level.

Levels: Enter number of levels.

Convert to 8 bits: this conversion is known as radiometric transformation and normally is utilized to
generate equalized mosaics as occupy less storage space.
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Click on the  Projection  button to  configure geographical  parameters.  Projection window opens.
Verify and correct if needed projection of the image.

Click on the OK button.

Confirm to see image on the visualization window.
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Applying Multi Resolution in an image

Given a raster data volume and the associated cost to its recovery in the database and subsequent
decoding before being used (visualization, for instance) it is allowed to the user store, besides matrix
data in its original resolution, sampled versions of data in degraded resolutions in several levels.

When importing a raster image it is possible to specify a pyramidal multi resolution application.
However, it can occur in the importation, a  multi resolution has not been applied or only after it
became needed.  Besides,  the resulting image of a register  operation is  not  generated with multi
resolution and could become necessary depending on the application.

The different resolution levels are identified by a factor that multiplies the original resolution. The
data set in different resolutions is called irresolution pyramid. Traditionally are created resolutions
with multiple factors in 2 times factor, so in each level ¼ of block numbers needed to store the image
in previous level (i.e., the better resolution).

Select IMAGE PROCESSING → FUNCTIONS → MULTI RESOLUTION in the main menu.

Layer: Select the layer where the multi resolution will be applied.

Multi Resolution Parameters: Select the type of building method.

Init Value for Multi Res: Enter initial value for multi resolution.

Last Value for Multi Res: Enter last value for multi resolution.

Click in OK button.
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Raster Overlay

Select IMAGE PROCESSING → FUNCTIONS → RASTER OVERLAY in the main menu.

View up: select the image from the list.

View down: select the image from the list.

Transparency: adjust it manually sliding the button or click on the  Automatic  button to automatic
slide button scan.

Flicker: adjust manually the flicker sliding the button.

Automatic Scroll: click on Vertical or Horizontal button to activate automatic scan on both axis.
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Raster Grouping

Select IMAGE PROCESSING → FUNCTIONS → RASTER GROUPING in the main menu.

Input Themes: select the image from the list. It appears in the left list below. Select the layer and on
the right arrow.

Output Layer:

Name: enter the name of the resulting image.

Projection: if not already defined click on this button to adjust it.

Raster identification: choose to use sequence value or layer identification
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Cutting Images

The data model of image type is directly responsible for the physical size of database occupying the
biggest store areas. It is worth to remember determined operations on the images uses huge computer
efforts.

To minimize this problem user can do a layer cut of image type thus excluding image regions that are
not part of the study area.

This  operational  is  very useful  in  many situations  such  as,  reduce  a  physical  size  of  database,
creation of smaller images to perform tests, image split in specific areas (city perimeter, chart sheets,
etc.) and generation of new images to printing layouts.

To do cuts, the user should define the limit of interest. This limit can be defined in three modes:

Vector:  from  a  vectorial  theme,  that  contains  polygon  type  geometries.  (Possibility  to  use  all
geometries in the layer or only selected ones by pointing).

Block: from definition of width and height of blocks

Region of Interest: from drawn polygons in the visualization area.

The result is a new layer of image type or a geotiff file 

Select IMAGE PROCESSING → FUNCTIONS → RASTER CUT in the main menu. Raster Cut
window opens.

Input Theme: choose from the theme list the target image.

Cut by: Select the parameter to be used to cut: vector, block or ROI.

Vectorial Theme: if vector is selected, enter the value from the scroll bar.

Group by Attribute: if selected select the attribute from the list.
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Use selected geometries by pointing: select this option if you want to choose the geometries.

Width block, height block: if block is selected enter the values for block width and height.

Acquire: if ROI is selected click on the Acquire button to define regions. ROI window opens.

Click on the icon  for rectangle selection of area,  for polygon selection of area, or  for magic
wand selection of area.

Slide button or type the number of threshold. 

Visual Transparency: change the opacity of defined polygons as samples.

Slide button or type the value of transparency percentage.

Click in OK button.

Back to Raster Cut window continue configuring output parameters.

Select Geo Tiff if image will be saved in a file. Select Layer if image is to be stored in the database.

Select  Generate  as  Unique  Image  if  only  unique  image  is  to  be  generated  including  all  cuts.
Otherwise, it will be generated new images depending on the number of cuts.

Select Generate Multi Resolution and enter the number of levels.

Base Name: Enter the theme name or the file name of cut image.
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Restoration

Restoration is a radiometric correction technique to correct distortions inserted by the optical sensor
in the digital image generation process.

It can be said that digital image is a dirty scene copy as the seen details in the scene are smoothed
due to sensor limitation.

The idea of image restore is to reduce this dirty defect and, therefore, obtain an improved image.

The correction is performed by a linear filter. The restoration filter weight is obtained from sensor
characteristics, and not in an empirical form as it is done in tradition improvement filters. In this
case, the filter is specific for each type of sensor and spectral band.

This type of processing is recommended to be performed on an original image without any other type
of processing such as filtering and enhancement that changes image radiometric characteristics. It
should be observed too it is not possible to process a resampled image once the image spatial and
radiometric characteristics have been changed.

Select IMAGE PROCESSING → FUNCTIONS → RESTORATION in the main menu. 

Input Image:

Sensor: select the sensor to be used.

Band: Select band number.

Output Parameters:

Generate Layer: click on this box if resulting image is to be saved in the database. Enter the name of
the new layer.

Generate TIFF: click on this box if resulting image is to be saved in a file. Click on the File button,
browse file path and enter a file name.

Pixel: Select the number of pixels. The processed image can be generated in a different scale from
the original, according to defined options.

Click on the OK button.
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Simplification

Simplification is  a  generalization  process  aiming  to  depict  the  element,  linear  or  superficial,
according to the representation scale.

When mentioning simplify the graphic representation of a geographic element in vector format, we
associate to the removal of some points that composes such element in a simpler presentation.

 Douglas Peucker Simplification

The purpose of the algorithm is, from a line shaped by a vertex set, to create another similar line but
with fewer vertexes. It is a recursive algorithm. Initially it selects the first and the last line points,
analyzes the line segment between these two points marking both points so they are kept. In this
analysis, it first locates the farthest vertex – in perpendicular distance – from created segment. If this
distance  between  the  vertex  and  created  segment  is  smaller  than  the  tolerance  value  used  (an
algorithm input parameter), then no points are marked to be kept but removed. However, in case this
distance is bigger than the tolerance then this vertex should be kept, and the algorithm is applied
recursively in  both  line  parts,  between  the  first  vertex  and the  farthest  vertex  and  in  sequence
between the farthest vertex and the last vertex. 

Effective Area Simplification

This algorithm consists of creating a triangle to each three consecutive vertexes of line and calculate
its  area.  The triangle  center  vertex  of  the smaller  area is  removed and the  algorithm is  applied
recursively using the remaining vertexes. The result when a certain condition is reached, e.g. a given

number or points are removed or an effective area of triangle reaches a pre-defined threshold. 
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Select IMAGE PROCESSING → FUNCTIONS → SIMPLIFICATION in the main menu. 

Input Layer: Select the layer to be processed.

Options:

Scale: enter the value of scale

Make a Copy of the Layer: click on this box if a layer copy is to be created in the database

Simplification Algorithms: Select one or more algorithm and click on the right arrow.

Click on the OK button.
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Raster slicer

Slicing consists of generating a classified image from the definition of pixel value intervals of the
input image, where each slice will be associated to a theme class. The definition of pixel intervals or
slices will depend on value variation of classes to be highlighted.

Select IMAGE PROCESSING → FUNCTIONS → RASTER SLICER in the main menu. 

Input Raster:

Layer: click on this button to select an image to be sliced.

Band:  select  the  band  to  be  used.  After  selecting  the  band,  a  histogram will  be  automatically
generated.

Use Only Visible Area: click on this box to process the visible area.

Select Workplace: click on this box if a specific condition is to be selected.
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Slices:

Initial: enter the initial value.

Final: enter the final value.

Class: enter the class name.

Color: click on this button to choose a color to the class.

Click on the icon  to insert the class on the list. If more classes are needed repeat the procedure.

If a class is to be removed from a list, select it and click on the icon .

Click on the icon  if a class file is to be loaded. 

Click on the icon  if defined classes are to be saved in a file.

Output parameters:

Generate Layer: click on this box if resulting image is to be saved in the database. Enter the name of
the new layer.

Generate TIFF: click on this box if resulting image is to be saved in a file. Click on the File button,
browse file path and enter a file name.

Click on the OK button.
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Features Extraction

Select IMAGE PROCESSING → FUNCTIONS → FEATURE EXTRACTION in the main menu.

Input Image:

Layer: select from the list the image to process.

Band: select one of the available bands.

Vector: click on vector and select the vectorial theme from the list. 

Use selected geometries by pointing: click on this box if the user wants to select geometries.

Region of Interest: choose this option to select specific areas. Click on the Acquire button and select
areas on the map.

Precision: enter the precision value.

Click on Select attributes. An expanded window appears.
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Select all attributes for feature extraction.

Click on the OK button.

Centralize polygon when selected: click on this box to centralize polygon.

Save table: click on this box to save the result. Enter the suffix.

Join columns to original layer: use this option to join the table column with the original ones.

Create new layer: use this option to save the result in a file entering its name in the field beside.

Note: when the last two options were done the user can can do polygon classification using Image
PROCESSING → SUPERVISED CLASSIFICATION selecting the option  Polygons Theme. For
more details go to Supervised Classification of Images.
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Raster Mask

A mask is a binary image of values 0 and 1. When a mask is used for a processing function, areas
under  value  1  are  processed  and  those  under  value  0  are  excluded  of  processing.  Among  the
functions that accept mask- applying, masks include statistical  calculation, classification, spectral
decomposition,  filtering,  continuity  removal  and  spectral  adjustment.  This  function  allows  the
definition of image masks per specific gray level values, per value ranges, per interest regions or
from annotation files.

Some of mask types are defined below:

Pixel Value: user defines a value so the mask can be created (e.g. pixel value 200) where defined
pixel value is found it will be created a mask.

Pixel range: user defines minimum and maximum values so a mask can be created.

Region of interest: to include regions of interest in mask definition.

Vector: uses as basis to mask cut a vector representation.

Invert mask: from a mask already created in black color it is possible to invert this mask to a white
color.

Select IMAGE PROCESSING → FUNCTIONS → RASTER MASK in the main menu.

Input Layer:

Layer Name: select one image from the list.

Band: select one of the available bands.

Mask: select one of the options and complete with the parameter aside.

Output Parameters:

Generate Layer: click on this box if resulting image is to be saved in the database. Enter the name of
the new layer.
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Generate TIFF: click on this box if resulting image is to be saved in a file. Click on the File button,
browse file path and enter file name.

Click on the OK button.
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Palette

LUT Controller

This function is used to modify a Look Up Table (LUT) table of a palette image. Each LUT table row
consists of an integer number that is the color index, the optional description of associated class to
the index, used in theme map images, and the color itself.

It is possible to include new rows and change the existent row contents (expect its index). It is not
possible the removal of table rows.

Select  IMAGE PROCESSING → PALETTE → LUT CONTROLLER in  the main menu.  Input
Raster: select one palette type image and then LUT table is showed below.

Class Information: choose to enter a new one or set as dummy.

Color: click on this button to change color of a selected class

Name: enter the name for this class and click on Save Entry button

Save ClassInfo as a file: click on this button to save classes to use in other tools. Browse the path and
enter the name to save the txt file.

Update Theme Legend: click on this button to update legend and present in the theme.
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Vector to Raster

This operation aims to create a new raster layer based on attributes values from a vector layer. Each
attribute of the vector layer is a band of the resulting raster.

Select IMAGE PROCESSING → PALETTE → VECTOR TO RASTER in the main menu.

Input Layer: select the layer to be processed.

Output Layer: enter the name of generated image.

Projection: click on this button to adjust projection parameters.

Raster Parameters:

Resolution: enter the value for X and Y resolution depending on the type of projection.

Dimension: enter the value for L and C dimension depending on the type of projection.

Click on the Next button.
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Class Definition:

One Class: click on this box if only one class will be used and select the color.

More Classes: click on this box if more than one class will be used.

Attribute: select one of available attributes.

Colors: select the color that will be used and click on the Apply button.

Save: click on this button if the setup is to be saved in a file.

Load: click on this button if a previous configuration from a file is to be loaded.

Class Selection Mode: choose to select or not all classes.

Click on the OK button.
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Majoritary Filter

Select IMAGE PROCESSING → PALETTE → MAJORITARY FILTER in the main menu.

Input Parameters: select the mode to be used: full or simple.

Number of Neighboring: select the number of neighbor pixels.

Replacement Threshold: select the replacement condition.

Output Parameters:

Generate Layer: click on this box if resulting image is to be saved in the database. Enter the name of
the new layer.

Generate TIFF: click on this box if resulting image is to be saved in a file. Click on the File button,
browse file path and enter a file name.

Click on the OK button.
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Raster Area

Select IMAGE PROCESSING → PALETTE → RASTER AREA in the main menu. 

Layer name: select one layer from the list.

Units: select what unit the result will be presented.

Click on Calculate button, classes and area will be presented in the list.

Save: click on this button if the value is to be saved in a text file.
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Validation

After the classification of an image the user can validate it to determine the reliability of the result.

Click on IMAGE PROCESSING → PALETTE → VALIDATION in the main menu.

Classified Image:

Layer Name: select the classified image to process.

Samples Layer:

Layer Name: Click on the Search button to open the list. Select a layer with the point view used to
generate the classification.

Class Column: select the column for validation. A list of classified image classes is showed. Choose
a class and enter the sample class number.

Click on the OK button.
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A report showing the number of computed samples, sampling factor, error rate and kappa index is
generated.
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Raster Spatial Operations

Select IMAGE PROCESSING → PALETTE → RASTER SPATIAL OPERATIONS in the main
menu.

Input Layers:

Select the first layer in the upper selection field.

Select the second layer in the lower selection field.

Only Visible Area: click on this box if the process is to be done in the visible area.

Spatial Operation: Select one of the three formats:

 Aggregate Area: Adds a new area to the polygon.

 Remove Area: Remove a determined area from the polygon.

 Unite polygons: Attach two or more polygons keeping the attribute of one of them.

Output Layer Name: enter the name of the resulting image.

Projection: click on this button to open projection window to adjust its parameters.

Resolution: enter the values for X and Y axis resolution.

Click on the OK button.
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Synthetic Aperture Radar (SAR)

Antenna Pattern Correction

Low frequency variation in image brightness in range direction is caused mainly by the power loss
related to the sight geometry that reduces at 1/R³ in SAR images, where R is the antenna distance in a
certain image point. 

This problem is more intense in plane-acquired images because Rmin (image range start) and Rmax
(range end) rate is smaller than image relation acquired by satellite where the rate is almost 1.

This power loss is corrected in acquisition moment of each pulse through STC (Sensitivity Time
Control)  intending to correct the power decrease.  Due to this  STC system imperfection or other
electronic  disturbances  of  radar  (amplifier  gain  variation  during  the  echo  acquisition  time),
mechanical or electrical, the correction is not perfect maintaining some residual variation

Antenna Pattern Correction

The algorithm consists in generating a pattern using image column average. The column average
must be chosen in regions (windows) as homogeneous as possible. It should be guaranteed that an
average exist in all range direction.

The resulting pattern from the column average must be filtered (adjusted) to obtain only the low
frequency variation. 

Select  IMAGE PROCESSING → SAR → ANTENNA PATTERN CORRECTION in  the  main
menu. 

96

Satellite

Airplane

Range

Rmin

Rmax



Chapter 3

Sample Acquisition: click on this button to collect samples.

Click on the icon  for rectangle selection of area,  for polygon selection of area, or  for magic
wand selection of area.

Click on the visualization area and drag the pointer to choose areas. The number of acquired samples
must cover all gray tone variation. 
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Click on the OK button.

Correction Method: select multiplicative or additive method.

Adjustment Method: select moving average or polynomial adjust.

Window: enter the filter window size to adjust.

Degree: select the polygon grade to adjust.

Click on the Adjust button.

Click on Preview button to verify the result in a chart.

Output Parameters:

Generate Layer: click on this box if resulting image is to be saved in the database. Enter the name of
the new layer.

Generate TIFF: click on this box if resulting image is to be saved in a file. Click on the File button,
browse file path and enter file name.

Click on the Bounding Box button to define a smaller area to apply the filter if wanted.

Click on the OK button.
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Slant Range to Ground Range Conversion

One type of geometrical distortion happens because of radar side sight. The obtained image has a
slant projection in relation to the ground creating an image compression. This compression varies in
the imaged extension. Closer the pixels are to radar, more compressed they will be.

The image conversion of a slant projection to a ground projection is called the slant to ground range
conversion.

A slant image is related with mode acquisition of side sight radars. 

The sampling process, that creates information in each reading interval, does not have the same area
to the samples in near range, in relation to samples in far range due to the incidence angle variation.

The generated image is called slant range. This image has a geometric distortion because slant range
samples,  equally spaced  in  imaged range,  are  not  equally spaced on the  ground,  ground range.
Therefore, the image can be registered and geocoded, the ground samples must be equally spaced
and slant range to ground range conversion is needed.

The conversion consists in project samples (pixels) on the ground and resamples them with a uniform
spacing. To do the conversion it is used parameters referring to SAR geometry such as flight height,
minimum distance (distance between sensor and first pixel), minimum time (time registered between
the sensor and the first pixel). Those parameters, in general, are available in selected image header. If
not, it should be filled in height and minimum slant distance fields, minimum incidence angle, or
minimum time fields. Any of last three parameters is enough to do the conversion. 

Another information to be considered is the imaging position: left side or right side, that can be
identified by the image shadows created by the side sight of SAR.
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Select  IMAGE  PROCESSING  →  SAR  →  SLANT  RANGE  TO  GROUND  RANGE
CONVERSION in the main menu

Flight Parameters:

Sensor elevation: enter the sensor elevation in meters.

Select one of the three options:

Minimum angle of incidence: enter the value in degrees or,

Minimum slant range: enter the value in meters or,

Minimum range delay: enter the value in milliseconds.

Image Position of Radar: select left or right.

Output Parameters:

Generate Layer: click on this box if resulting image is to be saved in the database. Enter the name of
the new layer.

Generate TIFF: click on this box if resulting image is to be saved in a file. Click on the File button,
browse file path and enter a file name.

Bounding Box: click on this button if a smaller area is to be defined.

Interpolar: select the proper condition.

Click on the OK button.
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Raster Remap

Select IMAGE PROCESSING → RASTER REMAP in the main menu.

Projection tab: 

Click on the box correspondent to the source image.

Note: if User Defined is selected click on the Projection button to do manual configuration.

Parameters tab:

Object:  select  one  of  the  available  objects.  These  are  object  identifiers  with  layer  matrix
representation that originated the theme.

Photometric: select bands on proper box for monochromatic or RGB channels and if available LUT
and multi resolution.

Use Theme Transformation:  applies the theme transformation in the output layer. Changes in the
relation channel x band, contrast are examples of transformations that can contain a raster theme. 

Convert to 8 bits: applies a radiometric transformation to the output data. 

Rescale: applies a calculation pixel = (pixel*100)+100 and this value is rescaled from 0 to 255.
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Resample Tab:

Dimension: select this box and enter number of lines and columns

Resolution: select this box to enter x and y resolutions.

Sampling: applies a scale factor in the output image. Only down sampling is available.

Output Tab:

Layer: click on this box to save resulting image in the database.

Name: enter the name of the layer.

File: click on this box to save resulting image in a file.

Format: select file format of saved file.

File: click on this button to browse path and enter a file name.

Name: enter the name of resulting image.

Use Only Visible Area: click on this box if process it to be executed in the visible area.

Generate Multi Resolution: click on this box to generate multi resolution images.

Use Dummy: click on this box if dummy pixels should be used.

Levels: select number of levels.
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Click on the OK button.

To see the image in visualization window click on the Yes button.
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Raster Viewer

Select IMAGE PROCESSING → RASTER VIEWER in the main menu.

Click on the File button to browse the path and select the image to be viewed.

In Raster Properties panel is presented all data related with the loaded image.

To zoom in image click on the icon  and then click on the visualization area.

To zoom out image click on the icon  and then click on the visualization area.

To zoom an area click on the icon  and then click the visualization area.

To move over the map click on the icon  and then click and drag on visualization area.

To recompose the image click on the icon  and then click on visualization area.
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4 Cloud Detection

CLOUD DETECTION MAIN WINDOW        106

PROCESSING CLOUDS AND SHADOWS        107

ADDING NEW THEMES        111

TerraAmazon has a plugin for cloud detection and processing.

To improve the definition of useful areas under clouds, it is necessary to detect cloud and shadow in
images.

This  tool  is  intended  to  speed  up  the  cloud  and  shadow detection  process  by means  of  image
processing  specific  techniques  applied  together  and  following  pre-defined  pattern  resulting  in  a
vectorial data representing analyzed objects.

Different from other used algorithms to detect such objects, this tool is able to detect this objects in
an image of any satellite, not being specific to some sensor type. It is also possible to use some image
extension types, such as TIFF, JPEG, etc.

To detect such objects it is necessary to define which image bands will be analyzed, i.e., the analysis
is  done in  distinct  bands of  the  image because each image band has  a  better  response to  each
spectrum interval. For instance, LANDSAT satellite images have a better definition of high radiance
objects such as clouds in band 1 while in band 4 it has a better definition for low radiance objects
such as shadows.
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Cloud detection main window

To open this plugin click on the icon  in TeraAmazon main menu. 

Cloud detection window opens.

Main menu: contains menu and action icons.  Icons in  this  plugin are  the same as in the Image
Processing plugin, see chapter 5 Tools. 

View/Themes: shows the views/themes tree.

Visualization area: shows picture of the selected image.
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Processing clouds and shadows

Click on CLOUD DETECTION → DETECTION in the main menu.

Cloud Band:

Database tab: click on the Search button to select the image and one of the available bands.

File tab: if the image comes from a file, click on this tab, click on the File button, browse and choose
the image file.

After selecting the layer or file, choose in field Band the appropriate band number to detect cloud.

Shadow Band:

Database tab: click on Search button to select the image and one of the available bands.

File tab: if the image comes from a file, click on this tab, click on the File button, browse and choose
the image file.

After selecting the layer or file, choose in Band field the appropriate band number to detect shadow.

File Projection:

Projection: click on this button to open projection window and adjust parameters if needed.

Click on the Next button.
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Click in Cloud and enter the minimum and maximum pixel value to isolate cloud objects.

Histogram analysis is generated in a chart to help define the interval.

Click in Shadow and enter the minimum and maximum pixel value to isolate shadow objects.

Histogram analysis is generated in a chart to help define the interval.

Note: A Histogram is a bar graph that show how frequently data occur within certain ranges of the
interval. The height of each bar gives the frequency in the respective interval. 

Note: in the histogram, there are specific controls (arrows) to navigate over it, zoom in and zoom
out certain intervals to better define values.

Morphologic Operator: these filters explore signal geometric properties (image geo levels). To these
filters masks are structure elements and present values 0 or 1 in the matrix (3x3 – center pixel and
neighbors)  that  correspond to the considered pixel.  Basic  morphological  filters  can are medium,
erosion and dilation.

Note:  if  morphologic filters  are not applied,  there will  not be the removal of small  rivers and
noises.

: click on the box to invert execution order.

Closing: click on this box and enter the value. Image closing generally chains erosion and dilation
filters with the same structure element to obtain closing effects. Obtained by dilation filter chain,
followed by erosion filter. Used to gulf removal and bay closing.

Opening: click on this box and enter the value. Image opening generally chains erosion and dilation
filters with the same structure element to obtain opening effects. Obtained by the erosion filter chain,
followed by the dilation filter. Used for isthmus break and cape and islands removal. 

Vectorizer Operation: click on the  Run Vectorizing  button if detection result will be generated as
vector data in the database. In this process, a raster data is transformed in vectorial data. Enter the
minimal area in meters for object detection.
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Note: it is only needed to define minimum area if the user wants to restrict object detection smaller
than x meters value.

Options:

Generate Intermediate Geo Tiff: click on this box if intermediate images generated will be saved in
TIFF extension files.

Click on Generate LOG File: click on this box if log files will be generated locally for analysis.

Output Layer: enter name to the new image.

Click in OK button.

To change the color of  contour and brush, right-click on the generated view and select Visual →
Default.

Change the color and click on the OK button.
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Adding new themes

It is possible to create new themes direct from Cloud Detection plugin.

Select EDIT → THEME in the main menu.

Input Parameters:

Infolayer: click on the Search button and select the image.

View: select the image view.

Theme Table:

Use left/right arrows to transfer tables to theme tables.

Properties: click on the Set Scale box and enter minimum and maximum values for the theme.

Theme Name: enter the name of the theme.
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DIP PLUGIN TOOLS                   114

TerraAmazon DIP Plugin has one tool bar in the main interface:
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DIP Plugin Tools

Tools to display and manipulate the both vector and raster data in the drawing area. All visualization
tools are effective on the drawing area only.

To use these tools, you must have a theme pointing to the data (layer) you wish to visualize or
manipulate.

To visualize the data  for the first  time after  connecting to the database,  select  the themes to  be
displayed by checking their check boxes on the Views and Themes tree.

Click on the tool  to visualize it in the drawing area.

The time required by the system to display the data on the drawing area depends on the amount of
data selected to be displayed and on how complex such data is. That is so because a theme can have
restrictions in order to point only to part of the data, which as a consequence makes the display
process concern only the data effectively pointed by the selected themes, instead of on the total
amount of data in their respective layers. Also, the time will depend on the area selected to be
visualized, that is, selecting the entire theme (using the Fit Theme option, for example) will result
in a larger amount of data to be drawn than it would be if a small area would be chosen. For the
same reason, visualizing data in a scale of 1:25.000 will be much faster than doing it on 1:100.000,
since more data will be visualized.

Information Cursor: queries the geometry´s attributes. Select the tool and on the desired
geometry. It has an effect on the geometry of the theme, which is active in the Views
and Themes tree.

When clicking in the intersection of two or more overlapped geometries the table will
show all geometries and each one can be selected individually.

Pan cursor.  Click and hold on the drawing area,  move to the desired direction and
release the click.

Draw tool. Triggers the data display in the visualization area. The data visualized are
determined by the themes,  which are selected on the Views and Themes tree.  That
means that TerraAmazon will display only the themes whose visualization scale range is
within the scale defined to be drawn. Drawing data for the first time will entirely fit all
the selected themes in the drawing area.  However,  the following visualizations will
resume the previous one, even after TerraAmazon is closed.

Zoom in. Select the tool and delimit the area to be visualized by holding a click in the
visualization area and drawing a rectangle involving the desired area.

Select an area to zoom.

Zoom out. Just click anywhere in the drawing area. Multiplies the visualization scale by
two.

Fits the selected theme in the drawing area.

  Previous and Next visualization.
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Recompose. Visualization is recomposed to a box that entirely contains the selected
themes. Only the themes whose visualization scale range is within the scale targeted by
the reset tool will be displayed. In case none of the selected themes are allowed to be
drawn in the targeted scale, then only the empty box will be drawn.

Indicate scale of showed picture.

Find in visualization area the position indicated coordinate.

Adjust an image contrast showed in the visualization window.

Adjust the image bright showed in the visualization window.

Adjust image transparency in the visualization window.

Adjust the color of RGB channels.

Read pixel value indicated by the pointer.

Create and organize new image views and tools to connect created views with the main
one.
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Abbreviations and Acronyms

CCD Charge Coupled Devide
CRA Centro Regional para Amazônica (Amazon Regional Center)
DEGRAD Sistema de Detecção de Áreas de Degradação Florestal na Amazônia Legal Brasileira
DBMS Database Management System
DEM Digital Elevation Model
DESM Dynamic Earth System Model
DETER Sistema de Detecção do Desflorestamento da Amazônica Legal Brasileira em Tempo 

“Quase” Real
DETEX Sistema de Detecção de Exploração Seletiva de Madeira na Amazônia Legal Brasileira
DIP Digital Image Processing
DTM Digital Terrain Model
EO Earth Observation
ETM+ Enhanced Thematic Mapper Plus
GCP Ground  Control Point
GIS Geographic Information System
HLS Hue, Saturation, Lightness
HRC High Resolution Camera
IHS Intensity, Hue, Saturation
LUT Look Up Table
OGC Open Geospatial Consortium
PALSAR Phased Array Type L-Band Synthetic Aperture Radar
PRISM Panchromatic Remote-Sensing Instrument for Stereo Mapping
PRODES Projeto de Monitoramento do Desmatamento na Amazônica Legal por Satélite
SWIR Shortwave Infrared
TERRACLASS Projeto de Mapeamento de Uso da Terra na Amazônia Legal Brasileira
TIN Triangle Irregular Network
TIR Thermal Infrared
TM Thematic Mapper
WFI Wide Field Imager
WMS Web Map Service
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